* FAQ  * Rechercher  * @Gimlao  * Mumble
 * Connexion
Nous sommes actuellement le Ven 23 Juin 2017 12:20:58
  Consulter les messages sans réponse
Consulter les sujets actifs



Publier un nouveau sujet Répondre au sujet  [ 6 message(s) ] 
Auteur Message
Message Publié : Lun 21 Août 2006 21:41:49    Sujet du message : Besoin de testeurs pour Gens et VBA
Avatar de l’utilisateur
Membre d'Or

Message(s) : 7777778
Inscription : 05 Jan 2005
Âge : 26
Localisation : Jamais loin d'une décharge sauvage

Je suis en train d'écrire un tuto sur les émulateurs pour Ubuntu (c'est aussi applicable pour d'autres distribs Linux), dans le but final de créer un dépôt de paquets spécial émulation.

Et j'ai deux émulateurs, et pas des moindres, qui me posent problème...
Gens (pour la Megadrive) et VBA (pour la GBA) ne me semblent pas très fonctionnels, le portage de Windows vers Linux a été pour le moins cahoteux...

Quelques exemples typiques pour VBA:
- son de très mauvaise qualité, crépitant
- malgré le frameskip, une vitesse d'émulation se stabilisant à 108%, ce qui explique certainement les crépitements
- des lenteurs inexplicables sur une GeForce4 après un agrandissement à facteur supérieur à 3
- des filtres qui ne marchent pas ou qui ne fonctionnent qu'avec un facteur d'agrandissement de 2, ce qui n'est très pratique

Et pour Gens:
- impossible d'avoir un facteur d'agrandissement supérieur à 2
- une fluidité douteuse, malgré les 60 FPS (j'ai vu mieux avec Gens+ sur Wine!)
- le filtre HQ2X qui est inefficace
- la plupart des touches raccourcis qui ne répondent pas, comme [F2], qui permet un frameskip automatique

Si je demande votre aide, c'est parce que j'ai fait mon enquête sur les principaux forums, et personne ne fait allusion à autant de problèmes... Pourtant, ces problèmes se retrouvent sur mes deux ordis et quelque soit la distrib!

C'est pour cela qui si vous pouvez essayer ces émulateurs sur Linux, dites-moi si vous rencontrez ces problèmes-là, et le cas échéant, je donnerai des alternatives, fonctionnelles cette fois!

Pour les utilisateurs d'Ubuntu, VBA (et son frontend VBAExpress) sont dispo dans le dépôt "multiverse":
• Code
sudo apt-get install visualboyadvance vbaexpress

Un paquet .deb de Gens peut être téléchargé sur Consolemul:
• Code
wget http://download.consolemul.com/Emulateurs/Megadrive/gens_2.12a-i386.deb
sudo dpkg -i gens_2.12a-i386.deb


N'oubliez pas de préciser les caractéristiques techniques de votre ordinateur!

Merci d'avance pour votre aide!

Image
Haut
Profil  
Message Publié : Mar 22 Août 2006 14:00:52    Sujet du message :
Avatar de l’utilisateur
2 Super Étoiles du Temps

Message(s) : 2400
Inscription : 13 Avr 2005
Âge : 30
Localisation : Gard (30), France

J'avais fait tourné VBA+VBAExpress sur mon ordi (avec Ubuntu) et j'avais moi aussi le problème du crépitement du son et du ralentissement si j'agrandissais trop.

Config du PC :
- Pentium 4 à 2.60Gh
- 768 Mo de RAM
- Radeon 9200 SE (x2 0o)
- Sound Baster Audigy SE (24 bits)

C'était évidament sous Ubuntu 6.06.

"La concurrence fait avancer le monde, pas les monopoles." Bigou
Image
Image
Haut
Profil  
Message Publié : Mar 22 Août 2006 16:38:46    Sujet du message :
Avatar de l’utilisateur
Membre d'Or

Message(s) : 7777778
Inscription : 05 Jan 2005
Âge : 26
Localisation : Jamais loin d'une décharge sauvage

Donc, ça a l'air d'être un problème pour toutes les machines, car ma carte vidéo est une NVidia GeForce4 et ma carte son une Realtek AC'97...

Quelqu'un pour essayer Gens?

Image
Haut
Profil  
Message Publié : Mar 31 Oct 2006 21:31:53    Sujet du message :
Anonyme

J'ai également quelques soucis curieux avec Gens, comme la fluidité que tu évoques (mais qui s'explique peut-être par mes gros problèmes d'OpenGL et carte graphique que j'expérimente depuis un moment déjà) mais aussi l'impossibilité de ripper en WAV (option grisée dans le menu !?), et d'autres détails qui ne me viennent pas immédiatement en tête.
Haut
 
Message Publié : Mer 01 Nov 2006 04:03:22    Sujet du message :
Avatar de l’utilisateur
Membre d'Or

Message(s) : 7777778
Inscription : 05 Jan 2005
Âge : 26
Localisation : Jamais loin d'une décharge sauvage

Ce qui soutient que mon idée que le portage de Gens sur Linux n'est pas très réussi...
Par contre, essayez Gens+ avec Wine, en mode GDI : le jour et la nuit ! En plus, toutes les raccourcis claviers fonctionnent, contrairement à la version Linux native. Seul le mode "Plein écran" ne marche pas... :-(

Et en remplacement de VBA, il y a le multi-émulateur libre Mednafen. Il est très fiable, comporte une foultitude d'options et de filtres ! Seul chose rebutante : pas d'interface graphique, il faut savoir bien maîtriser le shell pour dompter la bête. Ce qui ne m'a pas empêcher de l'adopter ! ;)

Image
Haut
Profil  
Message Publié : Dim 19 Nov 2006 01:10:48    Sujet du message :
Avatar de l’utilisateur
Membre d'Or

Message(s) : 7777778
Inscription : 05 Jan 2005
Âge : 26
Localisation : Jamais loin d'une décharge sauvage

Double-post, mais qui va apporter une solution native pour Gens.
En effet, devant la débandade qu'a représenté le portage de Sonic MD sur GBA, j'ai estimé nécessaire de me consoler en jouant à l'original avec Gens+, par l'intermédiaire de Wine.
Mais comme je l'ai dit avant, le mode plein écran ne fonctionne pas... C'est alors que je suis allé chercher sur Google s'il y avait eu des avancées à propos du portage de Gens sur Linux. Et comme par hasard, c'est sur le forum anglophone d'Ubuntu que je trouve une réponse: un paquet deb perso de Gens, compilé il y à peine deux semaines, avec plein de patches, le choix entre OpenGL et SDL pour l'affichage... Enfin bon, tous les désagrément cités avant, excepté le filtre HQ2X, ont été corrigés. Par contre, le dump WAV est toujours désactivé, mais il est toujours possible de faire une extraction à partir de son logiciel de capture audio.

Pour l'installer sur Ubuntu ou Debian: (une entrée dans la rubrique Jeux du menu devrait être ajoutée automatiquement)

• Code
wget http://tryagainprod.site.voila.fr/divers/gensforlinux_3.5rc_1_i386.deb && sudo dpkg -i gensforlinux_3.5rc_1_i386.deb

N'hésitez pas à l'utiliser (Fullscreen + VSync + Frameskip Nul + Scale2X = le bonheur) et à faire part de vos remarques.

PS: Je garde quand même Gens+ de côté, car pour les hoaxeurs, il est plus intéressant que le Gens original. Mais je privilègerai toujours la solution native.

Image
Haut
Profil  
Afficher les messages publiés depuis :  Trier par  
Publier un nouveau sujet Répondre au sujet  [ 6 message(s) ] 

Le fuseau horaire est UTC+1 heure [Heure d’été]


Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité


Vous ne pouvez pas publier de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum

Recherche de :
Aller vers :  
cron
Space Pilot 3K template by Jakob Persson
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Traduction et support en françaisHébergement phpBB